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Welcome to TechDig.    TechDig is a tool that allows you to digitize points from an image of a graph, 
usually scanned in from an article or paper.    This allows you to gain access to the data used to produce 
the graph, and perform analysis on or re-plot the data.    TechDig can read .bmp or .pcx files, or the image 
can be pasted from the clipboard.    You then define the axes, and digitize the graph using your mouse.    
The digitize data can then be copied to the clipboard or saved as an ASCII data file.

How to:
Get Started
Receive Support
Register

Commands
File menu
Edit menu
Mode menu
View menu
Help menu



Getting Started 

Digitizing data using TechDig is a five step process.

1)    Scan in your plot using your scanning software.    Copy the image to the clipboard, or save it in .pcx or
.bmp format.    It does not matter how the image in oriented.

2)    Load the image of the plot into TechDig.

3)    Define your axes.

4)    Digitize the data points.

5)    Save your data.



Loading the plot image 

Start TechDig, and import your image using the Paste command (from the Edit menu) or the Load Bitmap 
command (from the File menu).    TechDig supports Windows bitmap (.bmp or .dib) and .pcx files.    Only 
256 color and monochrome .pcx files are supported at this time.    Images can also be pasted from the 
clipboard.



Defining the axes 

Define the axes.    TechDig will first prompt you to right click on the origin.    After clicking on the origin, the 
Origin X and Y dialog box is opened, allowing you to enter the data coordinates of the origin.    After the 
origin is defined, you are prompted to right click on the last labelled point of the x axis, and the X Axis 
Limit dialog box is opened allowing the data cooridinate of the x-axis limit to be entered.    The same 
process is repeated for the y-axis.      After the axes are initially defined in this manner, the Plot Axes 
Settings dialog box is opened allowing any corrections in the axis parameters.    You can also specify 
logarithmic axes at this time.



Origin X and Y dialog box 

Enter the data coordinates of the origin of your plot into this dialog box.



X Axis Limit dialog box 

Enter the data coordinates of the last labelled point that you selected on your x-axis.



Y Axis Limit dialog box 

Enter the data coordinates of the last labelled point that you selected on your y-axis.



Digitizing the data

After the axes are defined, the data points are digitized simply by right clicking on the image of the plot.    
The actual points digitized may be modified by the settings under the Mode menu.    Mistakes can be 
deleted or modified using the Edit Data command, or the Undo command.    



Saving the data 

After digitizing the data, you can save it using the Save command.    The data is saved in plain ASCII 
format, which can then be imported into your spreadsheet or plotting program.    You can also copy the 
data to the clipboard using the Edit Data dialog box.



The "last labelled point" refers to the point on the axis that is as far as possible from the origin that has a 
known value for the data coordinate.    The idea is to define the scale of the axis in pixels/data unit as 
accurately as possible.



Click on the point with the secondary mouse button (usually the right), rather than the primary button 
(usually the left).    TechDig uses the right mouse button to select points on the image, in order to reduce 
the chance of accidentally entering points while scrolling the image or moving between applications.



Technical Support 

The author can be contacted at the following address (e-mail preferred):

Ronald B. Jones
3715 Lexington Dr.
Hoffman Estates, IL    60195
USA

e-mail: ronjones@xnet.com 

I also monitor the Intelec BBS net Shareware and Windows conferences.

All questions and comments are welcome.    Priority will be given to registered users.



Registration Information 
Thank you for your interest in TechDig.  TechDig is distributed as shareware. 
You may evaluate TechDig for a period not to exceed 30 days.  Following the 
evaluation period, if you wish to continue using TechDig, you must register.  
Upon registration, you will receive a key file which will eliminate the 
shareware reminder dialog box.

To register, first print out this registration form (using the File|Print 
Topic command in WinHelp).  Fill out the form and mail it with a check for 
US$12 to:

Ronald  B. Jones
3715 Lexington Dr.
Hoffman Estates, IL  60195
USA

If you have an Internet e-mail address and can accept your key file 
electronically, you may reduced your payment to $10.

Thank you for supporting TechDig!

TechDig Registration Form
Name:_______________________________________________________

Address:_______________________________________________________

_______________________________________________________________

_______________________________________________________________

_______________________________________________________________

E-mail Address:__________________________________________________

Comments:______________________________________________________

_______________________________________________________________

_______________________________________________________________

_______________________________________________________________



File menu commands

The File menu offers the following commands:

New Creates a new document.
Load 
Bitmap

Opens a .bmp or .pcx file that contains the image of your plot.

Save Saves the digitized data using the same file name.
Save As Saves the digitized data to a specified file name.
Exit Exits TechDig.



Edit menu commands

The Edit menu offers the following commands:

Undo Deletes the last digitized points
Axis Settings Edits the origin and axis positions and data coordinates.
Data Modify, delete or copy the digiitzed data to the clipboard
Copy Bitmap Copies the current image to the clipboard
Paste Bitmap Pastes an image from the clipboard

Mode menu commands

The settings in the mode menu determine how points are digitized when the right mouse button is clicked 
on your plot.    If none of the settings are selected, TechDig is in Normal mode.

Centroid 
Mode

Finds the centroid in a window around the cursor, when 
the right mouse button is clicked

Auto Line 
Mode

Attempts to automatically digitized a line



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version number of this application.



New command (File menu)

Use this command to create a new document in TechDig. This clears the current image and 
deletes all the digitized data.
 
Shortcuts

Toolbar:
Keys: CTRL+N



Load Bitmap command (File menu)

Use this command to load a plot image into TechDig.    TechDig can read .bmp and .pcx files.    Only 256 
color and monochrome .pcx files are supported.    If you have four or 16 color .pcx files, try converting 
to .bmp using Windows Paintbrush.    If there is sufficient interest and demand, other file formats may be 
implemented in future versions.  Contact the author with your suggestions.    

This command will errase any previously digitized data.    After the bitmap is loaded, you will be guided 
through the axis definition procedure.

You can delete all digitized data without loading a new image using the New command

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
.bmp for Windows bitmap files (sometimes have .dib extension)
.pcx for pcx files.    Only 256 color and monochrome .pcx files are supported.

Drives
Select the drive in which TechDig stores the file that you want to open. 

Directories
Select the directory in which TechDig stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Save command (File menu)

Use this command to save the digitized data to its current name and directory.    When you save data for 
the first time, TechDig displays the Save As dialog box so you can name your document.    If you want to 
change the name and directory of an existing document before you save it, choose the Save As 
command.    TechDig saves the data in a plain text ASCII file, which you can then import into a 
spreadsheet or graphics package.

If there is sufficient interest, various spreadsheet formats may be supported in future versions.    Do not 
hesitate to contact the author

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the current data.    TechDig displays the Save As dialog box so you 
can name your document.    

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:
File Name

Type a new filename to save a document with a different name.    A filename can contain up to eight 
characters and an extension of up to three characters.    TechDig adds the extension you specify in 
the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four image files you 
closed.    Choose the number that corresponds with the document you want to open.



Exit command (File menu)

Use this command to end your TechDig session.    You can also use the Close command on the 
application Control menu.    TechDig prompts you to save documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Undo Command (Edit Menu)

This command deletes the last point digitized.    If using AutoLine mode, all of the points digitized are 
deleted.    If you wish to delete points other than the last ones digitized, use the Edit Data command.

Shortcuts

Toolbar:
Keys: CTRL+Z



Copy Bitmap command (Edit menu)

Use this command to copy the current image onto the clipboard.    This command is unavailable if there is 
no current image.    To copy the digitized data to the clipboard, use the Edit Data command and copy the 
data from the Edit Data dialog box.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Paste Bitmap command (Edit menu)

Use this command to insert a new image fromt the clipboard.    This command will erase any previously 
digitized data (you will be prompted to save unsaved data).    This command is unavailable if there is no 
bitmap data on the clipboard.

Shortcuts

Toolbar:
Keys: CTRL+V



Axis Settings command (Edit menu)

Use this command to change the position in pixels or the data coordinates of the origin or endpoints of the
axes.    You can also specify logarithmic axes with this command.    This command opens the Plot Axes 
Settings dialog box.    Changes made to the axes are not reflected in previously digitized data points.



Plot Axes Settings dialog box 

This dialog box allows the axes positions and data coordinates to be modified.    The dialog box offers the 
following fields:

Origin position (pixels) (X and Y):    The screen position of the origin.    0,0 is in the upper left hand 
corner of the image.    Y values increase downward, X values increase to the left.

Origin Coordinates:    The coordinates of the origin in your data units, defined by the plot.

The following fields are repeated for the Y axis:

X Axis Limit Position (X and Y):    The position (in pixels) of the last labelled point of the X axis.

X Axis Limit Value:    The data coordinate of the last labelled point of the X axis.

Log Axis:    Check box for logarithmic axis.    This is only enabled if both the origin and limit coordinates 
are greater than zero.



Edit Data Command (Edit Menu)

Use this command to open the Edit Data dialog box, allowing you to modify or delete digitized data points.
You can also use this dialog box to copy digitized data to the clipboard.    After the dialog box is closed, 
the markers on the plot will be redrawn, reflecting your changes.



Edit Data dialog box 

This dialog box allows you to modify or delete your digitized points.    The dialog box offers the following 
fields:

Data grid:    Spreadsheet-like display of your digitized data.    You can select cells with the mouse, or by 
holding the shift key and using the arrow keys.    Double-clicking on a cell opens the Change Data dialog 
box, allowing the value to be changed (see Edit Value field below).

Edit Value:    Same effect as double-clicking on the data grid.    Allows you to change the current cell.

Delete Row:    Deletes the data in all selected rows.

Copy:    Copies all selected cells to the clipboard, in text format.

Clear All:    After asking for confirmation, this button clears all data.



Change Data dialog box 

This dialog box allows you to modify your digitized data.    The original value is in the Old Value field, and 
the new value is entered in the New Value field.



Centroid setting (Mode menu) 

This command toggles the Centroid mode.    In this mode, the centroid of all pixels in a 32x32 pixel that 
are not the background color (usually white) is calculated and digitized when you right click to digitize a 
point.

When centroid mode is active, the mouse cursor is changed to: 
The crosshairs indicate the center point, and the frame indicates the 32x32 window.

The centroid mode can increase accuracy, and is easier to use than normal mode, since you do not have 
to be as exact with the mouse.    However, there are cases where the centroid mode can lead to 

erroneous results.    For example, with sharply peaked data, a situation like:    

can lead to an erroneous result:      
In general you will have to experiment to gain a feel as to when centroid mode is appropriate.

The first time Centroid mode or Auto Line mode is activated for a plot, the color map will need to be built.

Shortcuts:

Toolbar:
Keyboard: F5



Auto Line setting (Mode menu)

The Auto Line mode attempts to automatically digitize a line.    When Auto Line mode is activated, the 

mouse cursor changes to:    
A portion of the line must fall within the 32X32 box outlined by the cursor when you right click.

The algorithm works best when the line is relatively smooth, and does not come near an axis or other line.

If the plot has sharp peaks, the algorithm will occaisonally halt at the peak.    Also, errorneous results can 
be obtained.    See Centroid mode for an example.

If the line comes near an axis, grid line, or another line, the algorithm may start following the other feature.
This can cause a large number of incorrect points to be generated.    The Undo command is very useful in
this case.

The first time Centroid mode or Auto Line mode is activated for a plot, the color map will need to be built.

Shortcuts:

Toolbar:
Keyboard: F4 (toggles the setting)



Normal mode

Normal mode is obtained when both the Centroid setting and the Auto Line setting are toggled off.    In 
normal mode, when you right click to digitize a point, the point at the crosshairs is used, without checking 
the image at all.    This mode gives the user the most control, but can be tedious for a large number of 
points.



Building the color map

When Centroid mode or Auto Line mode is activated for the first time for a plot image, TechGraf builds an 
internal map, indicating which pixels are background, and which are foreground.    This allows further 
Centroid and Auto Line calculations to be very fast.    However, it can take a significant amount of time for 
large images or slower computers.    A progress dialog box indicates how long it will take to complete the 
color map.    TechGraf remains active during this activity-- you can continue to move around the image 
and digitize points using normal mode.



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in TechDig, such as File Open.    A check mark appears next to the 
menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in TechDig,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Open a new document.

Open an existing document.    TechDig displays the Open dialog box, in which you can
locate and open the desired file.

Save the active document or template with its current name.    If you have not named
the document, TechDig displays the Save As dialog box.

Edit, delete or copy digitized data.

Change settings for axis position and limits.

Copy the bitmap to the clipboard.

Insert an image from the clipboard



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the TechDig window.    To display or hide the 
status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using TechDig and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of 
TechDig.



Context Help command 

Use the Context Help command to obtain help on some portion of TechDig.    When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and 
question mark.    Then click somewhere in the TechDig window, such as another Toolbar 
button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the TechDig window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.




